Troubleshooting strategies

This section provides links to information about troubleshooting:

  • Troubleshooting A-Z
  • Troubleshooting Stop messages: general strategies
  • Troubleshooting compatibility issues
  • Troubleshooting audio, imaging, and CD-burning peripheral devices
  • Getting older programs to run on the Windows Server 2003 family of products
  • Using Event Viewer
  • Using Shutdown Event Tracker
  • Using online resources
  • Troubleshooters


Troubleshooting compatibility issues

What problem are you having?

An application stops responding, quits, or behaves improperly.

Cause: The version of the application is not compatible with this version of Windows.

Solution: Start the Program Compatibility Wizard to detect and test compatibility settings. To start the Program Compatibility Wizard, click Start, click Run, and then type hcp://system/compatctr/compatmode.htm.

See also: Accessing information about compatibility; Troubleshooting specific Stop messages

Cause: The display settings are not correct.

Solution: Some older games and applications may require a 256-color quality or 640 x 480 screen resolution to function properly. Use the Display Properties dialog box to change the display settings. XOX

See also: Display Properties overview

Notes

  • XOX
  • For more information about the Program Compatibility Wizard, see Getting older programs to run on the Windows Server 2003 family of products.

Hardware does not function properly.

Cause: The hardware is not compatible with this release, or it needs to be updated to work with this release.

Solution: To confirm that your hardware is designed for the Windows Server 2003 family, see the compatibility information in Support resources.

See also: Hardware compatibility

Notes

  • For the latest information about products that are designed for the Windows Server 2003 family, see Hardware compatibility information in the Windows Catalog at the Microsoft Web site. (http://www.microsoft.com/)
  • For more information about the Designed for Windows logo program, see Designed for Windows at the Microsoft Web site. (http://www.microsoft.com/)


Troubleshooting audio, imaging, and CD-burning peripheral devices

What problem are you having?

The audio device does not work.

Cause: If you receive the following message: "The service cannot be started, either because it is disabled or because it has no enabled devices associated with it," the device requires that the Windows Audio service be enabled. By default, the Windows Audio service required by this peripheral device is started only on computers running Windows Server 2003, Standard Edition.

Solution: If sound is required, start this service, and then set Startup type to Automatic.

Most peripheral devices are supported by drivers on the installation CD for the Windows Server 2003 family. If the CD does not list a driver for your device, look for an update from the device manufacturer or from Windows Update. To check if your hardware is compatible, see Support resources.

See also: To start, stop, pause, resume, or restart a service; To configure how a service is started

Note

  • The hardware drivers for this peripheral device cannot be updated unless the Windows Audio service is started.

The imaging device does not work.

Cause: If you receive the following message: "The service cannot be started, either because it is disabled or because it has no enabled devices associated with it," the device requires that the Windows Image Acquisition (WIA) service be enabled. By default, the Windows Image Acquisition (WIA) service required by this peripheral device is disabled.

Solution: If imaging is required, start this service, and then set Startup type to Manual.

Most peripheral devices are supported by drivers on the installation CD for the Windows Server 2003 family. If the CD does not list a driver for your device, you can look for an update from the device manufacturer or from Windows Update. To check if your hardware is compatible, see Support resources.

See also: To start, stop, pause, resume, or restart a service; To configure how a service is started

Note

  • The hardware drivers for this peripheral device cannot be updated unless the Windows Image Acquisition (WIA) service is started.

The CD-burning device does not work.

Cause: The IMAPI CD-Burning COM Service required by this peripheral device is disabled.

Solution: If CD burning is required, start this service and set Startup type to Manual, and then restart the server.

Most peripheral devices are supported by drivers on the installation CD for the Windows Server 2003 family. If the CD does not list a driver for your device, you can look for an update from the device manufacturer or from Windows Update. To check if your hardware is compatible, see Support resources.

See also: To start, stop, pause, resume, or restart a service; To configure how a service is started

Note

  • With some third-party software, you may be able to burn CDs without starting the IMAPI CD-Burning COM Service.


Using Event Viewer

You can use Event Viewer to monitor events that are recorded in the Application, Security, and System logs. By using the event logs in Event Viewer, you can gather information about hardware, software, and system problems. You can also monitor security events. For more information, see Event Viewer.


Using Shutdown Event Tracker

Shutdown Event Tracker provides a simple and standard mechanism that you can use to consistently document the reasons for shutting down or restarting your computer. You can then use this information to analyze the root causes of shutdowns and to develop a more complete understanding of your system environment. For more information, see Shutdown Event Tracker.


Using online resources

The Microsoft Web site contains support information, including the latest downloads and Knowledge Base articles written by support professionals at Microsoft:

  • Product Support Services.(http://www.microsoft.com/) Search frequently asked questions (FAQs) by product, browse the product support newsgroups, and contact Microsoft Support.
  • Search the Knowledge Base.(http://www.microsoft.com/) Search the Microsoft Knowledge Base of technical support information and self-help tools for Microsoft products.
  • Windows Server Community.(http://www.microsoft.com/) The official online community for enthusiasts of the Windows server operating systems.
  • Windows Deployment and Resource Kits.(http://www.microsoft.com/) Find information about the Windows Deployment and Resource Kits that are available for Windows products.
  • Windows Resource Kits—Web Resources.(http://www.microsoft.com/) Find information about and resources for a variety of Windows topics.
  • Microsoft TechNet.(http://www.microsoft.com/) Search for troubleshooting information, service packs, patches, and downloads for your system.


Troubleshooters

Troubleshooters are tools that walk you through technical problems that might occur with your computer. For more information, see the following:

  • Using troubleshooters
  • List of troubleshooters